KB#0102 Expired GPG Key causes node installation to fail in Puppet Enterprise 2016.2 and earlier

Comments

3 comments

  • Avatar
    Abhinav Santi

    Hello,

    The article above says only about new installations.How do I update the expired keys for existing nodes?

    Thanks in advance!

  • Avatar
    Suzie Baunsgard

    Hi, it's possible that this might help you: https://support.puppet.com/hc/en-us/articles/236358027 . If it does let me know and I'll go ahead and add the link at the top to help people find it.

    I've asked the person who wrote the article to come take a look as well, so we can get you some help on this.

  • Avatar
    Charlie Sharpsteen

    Hi Abhinav,

     

    Access to an unexpired GPG key is only required when installing or upgrading the puppet-agent package on a Debian or Ubuntu node. For the case of an upgrade, I would recommend upgrading to at least the latest LTS release (2016.4.3 as of this posting) which is unaffected by the expired GPG key.

    If the question is about an expired _agent certificate_ and not the package GPG key, then the article Suzie linked should provide a good starting point for getting a new agent certificate set up.

    Hope this helps!

Please sign in to leave a comment.