KB#0305 How do I use SFTP to upload files to Puppet support?

Comments

3 comments

  • Avatar
    Alex Mesfin

    Hi,

    I am getting this error:

    [root@dccdvtp001 ~]# /opt/puppetlabs/bin/puppet enterprise support --v3 --ticket 37116 --upload --upload-user amesfin
    Error: Could not parse application options: invalid option: --upload

    Alex Mesfin

    0
    Comment actions Permalink
  • Avatar
    Suzie Baunsgard

    Hi, it looks like you're getting help already, I've let those folks know that you've left a comment here. If we can make improvements to the article based on your experience, we will do it.

    0
    Comment actions Permalink
  • Avatar
    Charlie Sharpsteen

    Hi Alex,

    The most common explanation for that error is that your PE version is older than the --upload feature. This flag was added to the LTS in 2018.1.8 and to the STS in 2019.0.3.

    Older PE versions will produce the "invalid option" error that you are seeing.

    0
    Comment actions Permalink

Please sign in to leave a comment.