Some of the modules you’re using aren’t working as expected. When you check for module issues by running
puppet module list --debug, you get a list of dependency warnings. Learn how to fix these warnings and how to avoid issues in the future.
Error messages and logs
When you run
puppet module list --debug on the primary server, you get module dependency warnings, for example:
Warning: Module 'puppetlabs-stdlib' (v8.4.0) fails to meet some dependencies: 'puppetlabs-change_window' (v0.2.0) requires 'puppetlabs-stdlib' (>= 2.4.0 < 7.0.0) 'puppetlabs-wsus_client' (v4.0.0) requires 'puppetlabs-stdlib' (>= 4.6.0 < 8.0.0)
When you use a Puppetfile to manage your code repos, you must also declare any required dependent modules. Dependencies for modules are not automatically resolved.
Version and installation information
PE version: All supported
To fix the issue, complete the following steps.
On the primary server, check for module issues by running
puppet module list --debug
Go through any errors in the output and note the dependencies that you need for each module. For more information on dependencies for each module, refer to module documentation on the Forge. For more Puppetfile information, please refer to Managing environment content with a Puppetfile .
Note: If the version numbers in the dependencies don’t make sense, for example,
The requested version cannot satisfy one or more of the following installed modules: puppetlabs-stdlib, installed: 7.1.0, expected: >= 4.0.0 < 9.0.0, you might have more than one module installed that require different versions of the same dependency.
Update your Puppetfile to resolve dependency issues.
Prevent future issues by checking dependencies when installing and upgrading modules. You can check them automatically using the
How can we improve this article?
Please sign in to leave a comment.